Jump to content

Royal Caribbean Website Pain


Recommended Posts

2 minutes ago, pcur said:

 ...

 

I was browsing and researching for an assisted living center for my MIL, and the next day I went to check Yahoo news, and it was "littered" with assiste living ads!  Annnnnooooooyyyyying

 

You've got to use the private mode all the time.

Link to post
Share on other sites
11 minutes ago, Host Clarea said:

 

You've got to use the private mode all the time.

I would if I could change the color scheme.  That black drives me nuts if I have the window open for very long. So, I just clean it out automatically when I close the browser.  Roboform logs me into everything (Google, mail, etc.) in about 3 seconds each, so it's not to inconvenient.  

Link to post
Share on other sites
4 minutes ago, pcur said:

I would if I could change the color scheme.  That black drives me nuts if I have the window open for very long. So, I just clean it out automatically when I close the browser.  Roboform logs me into everything (Google, mail, etc.) in about 3 seconds each, so it's not to inconvenient.  

 

Check for add-ons too. There are several privacy add-ons that help defeat the tracking.

Link to post
Share on other sites

Anyone else having issues with cruise critic on mobile?  It's signed me off and none of the selections to sign in are working (no action when i select the Sign In button or the option to sign in from the top right corner)

Link to post
Share on other sites
Just now, LuCruise said:

Anyone else having issues with cruise critic on mobile?  It's signed me off and none of the selections to sign in are working (no action when i select the Sign In button or the option to sign in from the top right corner)

 

Check this forum for CC website issues: 

https://boards.cruisecritic.com/forum/859-need-help-using-the-forums-check-here/

Link to post
Share on other sites

I dont see newer topics, so wondering...am I the only one who cannot log in to royal's website the last few days?

It goes to the signin url, loads 75% across the top, and then just hangs forever.

 

Anyone else see this? I cleared history on browser, and tried chrome and MS Edge.

 

 

 

Link to post
Share on other sites
8 minutes ago, nc2sc said:

I dont see newer topics, so wondering...am I the only one who cannot log in to royal's website the last few days?

It goes to the signin url, loads 75% across the top, and then just hangs forever.

 

Anyone else see this? I cleared history on browser, and tried chrome and MS Edge.

 

 

 

 

Not having a problem with Firefox or IE.

Link to post
Share on other sites
7 hours ago, nc2sc said:

I dont see newer topics, so wondering...am I the only one who cannot log in to royal's website the last few days?

It goes to the signin url, loads 75% across the top, and then just hangs forever.

 

Anyone else see this? I cleared history on browser, and tried chrome and MS Edge.

 

 

 

 

You might try an incognito/private browser window.

Link to post
Share on other sites
  • 2 weeks later...

It seems the past cruises tab of our webpage has changed. It now shows the most recently completed cruise immediately.

 

Just not the points😉

 

842714532_RCIptshistory.jpg.74419a8b7c32e19793136063a255af9c.jpg

 

I swear this wasn't like this last week.

 

Anyone notice any other modifications?

 

DID NOT REALIZE THIS QUALIFIED AS A WEBSITE PAIN.

SEEMED TOPICAL ENOUGH FOR IT'S OWN THREAD

FOLKS ASK ALL THE TIME WOW LONG IT TAKES FOR CRUISES TO POST

 

I GUESS WE CAN GO BACK TO COMPLAINING ABOUT SHORTS IN THE MDR

Edited by John&LaLa
Link to post
Share on other sites
On 7/8/2019 at 2:06 PM, nc2sc said:

I dont see newer topics, so wondering...am I the only one who cannot log in to royal's website the last few days?

It goes to the signin url, loads 75% across the top, and then just hangs forever.

 

Anyone else see this? I cleared history on browser, and tried chrome and MS Edge.

 

 

 

 

This exact problem was happening to me in chrome a week ago. I was able to get in via incognito mode. I absolutely refuse to delete my entire browser cache for anyone (probably haven't done so in years) so I work on every angle to resolve. I did try deleting Royals site cache only and that didn't help.

 

I found other browses worked like Edge so I'm not sure how you had the issue in both I Think IE worked but I might be wrong). I did see that when I accessed the site from my work computer it was fine in chrome, so the issue appeared to be local computer and/or browser specific in my case.

 

After a few days maybe a week it all started working by itself again. I login to the site almost daily looking for deals I might have missed on a cruise that's a little more than 3 months out. Overall the site seems to work fine but has some formatting issues

 

 

Link to post
Share on other sites
1 minute ago, Tahina cruising said:

I have 89 days until my cruise on Freedom of the Seas. The link says Start Check in but when I click on it nothing happens. Is something wrongs with the website? I tried yesterday at 90 days and it wouldn't work either.

 

Try the normal fixes:  clear cookies, clear cache, private browsing mode, different browser.

Link to post
Share on other sites
7 minutes ago, Tahina cruising said:

I have 89 days until my cruise on Freedom of the Seas. The link says Start Check in but when I click on it nothing happens. Is something wrongs with the website? I tried yesterday at 90 days and it wouldn't work either.

 

I have the same issue as you - called Royal Saturday & was told "they are working on your record & will email you when they are done", gave me a ticket# for whatever that is worth. 

 

I have tried the normal fixes & still not able to check-in.  Not holding out much hope they will have it resolved before our cruise, so will just show up at port & they will have to look us up manually. 

Link to post
Share on other sites
16 hours ago, John&LaLa said:

 

DID NOT REALIZE THIS QUALIFIED AS A WEBSITE PAIN.

SEEMED TOPICAL ENOUGH FOR IT'S OWN THREAD

FOLKS ASK ALL THE TIME WOW LONG IT TAKES FOR CRUISES TO POST

 

I GUESS WE CAN GO BACK TO COMPLAINING ABOUT SHORTS IN THE MDR

I think your CAPS LOCK is stuck 😘

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Jump
    • Categories
      • Forum Assistance
      • Holiday Exchange - Jingle and Mingle 2020
      • Q&A: Cruise Insurance with Steve Dasseos of TripInsuranceStore.com
      • Q&A with Chris Prelog, President of Windstar Cruises!
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...