Jump to content
Cruise Critic Community
CanICruiseSoonPlease

Princess website still down?

Recommended Posts

8 minutes ago, CanICruiseSoonPlease said:

I cant go on from google chrome, but can from IE and my phone.  Just tried

I just tried Explorer too and got through!  Evidently it doesn't like Chrome right now.

Share this post


Link to post
Share on other sites
3 minutes ago, 1emerald1 said:

I just tried Explorer too and got through!  Evidently it doesn't like Chrome right now.

And I got the original version back! 

Share this post


Link to post
Share on other sites

I 'm using Firefox and can't get past the log in page.

Final payment is due next week.

 

I hope this doesn't take as long as the Medallion to fix.:classic_ohmy:

Share this post


Link to post
Share on other sites

Got in on Chrome just now. All functions seem to be working. Maybe some of you need to clean out your cache?

Share this post


Link to post
Share on other sites

If you can access a website on one device but not another, you most likely are having a problem with your device (computer/smart phone etc) and need to clean out the browser or even reboot the device.  The other option is that they have changed some of their code and your device/browser has a problem with the change.  In that case always try another browser like chrome, firefox or IE.  I have had cases where chrome could not handle the changes but IE could. 

Share this post


Link to post
Share on other sites
13 minutes ago, satxdiver said:

If you can access a website on one device but not another, you most likely are having a problem with your device (computer/smart phone etc) and need to clean out the browser or even reboot the device.  The other option is that they have changed some of their code and your device/browser has a problem with the change.  In that case always try another browser like chrome, firefox or IE.  I have had cases where chrome could not handle the changes but IE could. 

That is exactly what happened to me.  Chrome still showing tech.difficulties, but got in easily on Edge and IE.

 

Pooh

Share this post


Link to post
Share on other sites

Chrome tends to push the envelope as far as website security goes. They have made a lot of changes recently and website owners have been scrambling to keep up.

You may need to refresh your browser, clear history, cookies etc. You may even be running an older version of Chrome, Firefox, etc. Check for browser updates, which should always be kept up to date anyway.

 

Edited by TriumphGuy

Share this post


Link to post
Share on other sites

Webpages are designed according to the latest industry standard and release to be used by any device or browser.  The browser and device creators then design their browser/device to handle the standardized code used by the web designer.  Problem appears when the standard code used by everyone changes in some small way usually to correct a problem or add new features.  The web designer uses those changes but sometimes the browser/device folks do not all make the change.   The other problem already mentioned that one must keep their browser and devices up to date with the latest standard.  Browsers remember a lot of details in their cache and use these details unbeknownst to the user when accessing a webpage.  Always flush your browser cache so that it has to recreate the cache.  The reason they keep the cache is so that when you look at the same webpage again, the browser can bring it up faster.  

Share this post


Link to post
Share on other sites

I still can't get past the 'technical difficulties' page on my computer.  Cell phone seems ok.  Any suggestions to fix?  Have done my computer updates and restart but didn't help.  everything else seems to be working ok.

Share this post


Link to post
Share on other sites
47 minutes ago, Rocking Waves said:

I still can't get past the 'technical difficulties' page on my computer.  Cell phone seems ok.  Any suggestions to fix?  Have done my computer updates and restart but didn't help.  everything else seems to be working ok.

What browser are you using? I was using Chrome then someone on the boards recommended IE and when I switched to that I have no problems now.

Share this post


Link to post
Share on other sites

I’ve had a problem intermittently on both iPad and Mac book air for a couple of weeks. To the point that my iPad is mostly useless for Princess.  So annoying. I downloaded Microsoft Edge search engine and now my iPad works with the website again

 

Edited by HaveDogWillTravel

Share this post


Link to post
Share on other sites

I just found that microsoft edge (new IE) works better on the Princess website than chrome and to my surprise has the old planner format.  The new fancy planner format takes too long to load on my desktop maybe due to my slower internet speed (20+ mbps) and I can do without the graphics.  

Edited by satxdiver

Share this post


Link to post
Share on other sites

I AM HAVING PROBLEMS ON BOTH MAC COMPUTERS FOR A WEEK NOW.

 

I was just able to purchase items for my booking, but it still won't let me fill in the personal info. etc. on the personalizer.

 

Share this post


Link to post
Share on other sites

IE from home office desktop - mostly no problems except normal Princess outages / maintenance

 

Never saw a "new version"

Share this post


Link to post
Share on other sites

It is sounding to me that the folks who are experiencing issues are Apple product users.  I'm interested to know if any PC users are experiencing problems.  How about it - would those experiencing problems let us know what hardware you are using (Apple or PC?)

 

P.S. I have been using IE on a PC and didn't even know others were having a problem until I saw this thread.  I've been in and out of my personalizer many times since Saturday.

Share this post


Link to post
Share on other sites
On 12/9/2018 at 4:41 PM, TriumphGuy said:

There was a notice yesterday that parts of the site would be unavailable from 8am (pst) to 11pm today (Sunday 12/9) due to site maintenance.

 

Parts of the site are still unavailable to me.  “Sorry for the inconvenience...”.  I’m on my iPad and haven’t attempted to get on on any other device.

Share this post


Link to post
Share on other sites
28 minutes ago, Daniel A said:

 

 

P.S. I have been using IE on a PC and didn't even know others were having a problem until I saw this thread.  I've been in and out of my personalizer many times since Saturday.

 

The only problem I’ve found this morning is in pricing specific cruises.  Some work, some don’t.  I’ve had no problem getting into my personalizer.  As I mentioned above, I am on an iPad.  Perhaps all will soon be fixed! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Forum Jump
    • Categories
      • Forum Assistance
      • Q&A: Cruise Insurance w/ Steve Dasseos of the TripInsuranceStore.com June 2020
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Member Cruise Reviews
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations

Announcements

×
×
  • Create New...