Jump to content

Recommended Posts

The last time we tried to us this is didn't work very well. I don't know if it was the ship's internet or not. We were on the Legend. We cruised with family that time and everyone was having issues. This time it will be just my husband and I, so we would only use it for the schedule. I personally think it was an issue with the ships internet. 

 

What are other people experience with it?

Link to post
Share on other sites

It's hard to tell why you were experiencing problems. My first guess would be the ship's internet because quality varies greatly throughout the fleet. That's something they've been improving in the last couple years, but there's still ships out there with terrible internet speeds. At least at times. Then again, it could've been the app acting buggy. I don't think the Hub app is too terribly demanding when it comes to bandwidth, so overall, it should work well. We were on Glory in 2018 and our internet service was absolutely atrocious, but the Hub app still worked well. What ship are you going on next? The Vista, Horizon, Sunrise, & Panorama have the best internet service in the fleet. You shouldn't have any problems if it's one of those.

Link to post
Share on other sites

What device are you using? When i was on the Sunrise back in June, the ios version of the app was very buggy. very slow and sometimes freezes. My android device did not had this problem. could be an issue with app on apple devices

Link to post
Share on other sites
5 hours ago, shof515 said:

What device are you using? When i was on the Sunrise back in June, the ios version of the app was very buggy. very slow and sometimes freezes. My android device did not had this problem. could be an issue with app on apple devices

We sailed with family this time. One had iPhone and we had Android. Both had issues connecting up. 

Link to post
Share on other sites
5 hours ago, Organized Chaos said:

It's hard to tell why you were experiencing problems. My first guess would be the ship's internet because quality varies greatly throughout the fleet. That's something they've been improving in the last couple years, but there's still ships out there with terrible internet speeds. At least at times. Then again, it could've been the app acting buggy. I don't think the Hub app is too terribly demanding when it comes to bandwidth, so overall, it should work well. We were on Glory in 2018 and our internet service was absolutely atrocious, but the Hub app still worked well. What ship are you going on next? The Vista, Horizon, Sunrise, & Panorama have the best internet service in the fleet. You shouldn't have any problems if it's one of those.

 

We were on the Legend. Normally internet is slow, but was abnormally slow. I could only check my email twice on a 7 day trip and then it took me forever. I think we were in port in Cozumel. So I don't remember if I using local towers or not. But on the ship it was impossible if not rare to get connected even to the Hub App. I even went to the "internet guy", everything looked correct. 

Link to post
Share on other sites

Are you all sure the Hub App works off the same wi-fi you buy on the ship? This is not my understanding. I'm sure I'll be corrected if wrong. I thought the Hub App worked independently from the paid wi-fi

Link to post
Share on other sites
1 hour ago, Kudos2Fly said:

 

 But on the ship it was impossible if not rare to get connected even to the Hub App. I even went to the "internet guy", everything looked correct. 

 

It seems with the newer Hub app, carnival changed the hub app to work via internet instead of the local intranet like how it was before. Since internet connection is always crap at sea, this could cause the slowness and other connection issues. it is a stupid move on carnival part do this, but carnival IT department seems horrible with all of the issues the website is having

Link to post
Share on other sites
11 hours ago, Kudos2Fly said:

The last time we tried to us this is didn't work very well. I don't know if it was the ship's internet or not. We were on the Legend. We cruised with family that time and everyone was having issues. This time it will be just my husband and I, so we would only use it for the schedule. I personally think it was an issue with the ships internet. 

 

What are other people experience with it?

What exactly was the problem? You have to leave the app open in the background in order for the messaging feature to work (if that was the issue).

Link to post
Share on other sites
6 minutes ago, shof515 said:

 

It seems with the newer Hub app, carnival changed the hub app to work via internet instead of the local intranet like how it was before. Since internet connection is always crap at sea, this could cause the slowness and other connection issues. it is a stupid move on carnival part do this, but carnival IT department seems horrible with all of the issues the website is having

Thanks for the information. Maybe this time it will work better. 

Link to post
Share on other sites
40 minutes ago, coevan said:

Are you all sure the Hub App works off the same wi-fi you buy on the ship? This is not my understanding. I'm sure I'll be corrected if wrong. I thought the Hub App worked independently from the paid wi-fi

You are correct. You don't need to buy a WiFi package to use the Hub app.

Link to post
Share on other sites
5 minutes ago, Sean_B said:

What exactly was the problem? You have to leave the app open in the background in order for the messaging feature to work (if that was the issue).

We would use the App to try to connect up at a current time and my husband's son never got the message through the Hub App. But a few times it did work. The app was running in the back ground. 

Edited by Kudos2Fly
Link to post
Share on other sites
Just now, Kudos2Fly said:

We would use the App to try to connect up at a current time and my husband never got the message through the Hub App. But a few times it did work. The app was running in the back ground. 

 

That sounds like a ship issue. If something isn't working the way it should, your best bet is to hit up Guest Services and find out if there is a problem with their system. 

Link to post
Share on other sites

Thanks for the reply's. I just downloaded the Hub App and signed in. I'll get my husband to do the same before the cruise. Hopefully it will work better. We always buy WiFi and never really has any issues, but on the Legend it was worse then normal. So maybe it was a ship issue. I know you don't need Wifi for the Hub, but we get it to check emails and other work related things. 

Edited by Kudos2Fly
Link to post
Share on other sites
46 minutes ago, Kudos2Fly said:

Thanks for the reply's. I just downloaded the Hub App and signed in. I'll get my husband to do the same before the cruise. Hopefully it will work better. We always buy WiFi and never really has any issues, but on the Legend it was worse then normal. So maybe it was a ship issue. I know you don't need Wifi for the Hub, but we get it to check emails and other work related things. 

 

You don't even need to login to your Carnival account through the Hub app to use all of its features once you get onboard. Logging into your Carnival account just allows it to sync your next cruise for the countdown clock (which can be done manually without logging it) and allows the app to redirect you to your account on Carnival's website. I wish we could do stuff like make FunShop purchases directly from the app, but all it does is redirect to Carnival.com.

 

Once you're onboard, instead of using your Carnival login, you login to the app using your folio and birthday (I think).

Link to post
Share on other sites

Magic was good but not perfect. We used it for dining, schedules, and texting. For whatever reason the texting wouldn't always work and between two families had a mix of Android and iPhone and both had problems on occasion. With that said, it wasn't overly bothersome and tolerable through the week for what we used it for. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Jump
    • Categories
      • Forum Assistance
      • SPECIAL ANNOUNCEMENT: Azamara - We are back with New Greece Voyages
      • SPECIAL EVENT: Q&A with Barbara Muckermann, CMO Silversea Cruises
      • ICYM Our Cruise Critic Live Special Event: Explore the Remote World with Hurtigruten!
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • Canadian Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...