Jump to content

Microsoft Edge issue


Recommended Posts

Anyone else having problem signing into Cruise Critic using Microsoft Edge browser?  I get black screens or flashing white screens but it never fully loads.  Thought it might be my computer but I'm using Chrome right now and it's fine...anyone else experiencing this on MS EDGE?

Link to post
Share on other sites
4 hours ago, Gracie115 said:

Anyone else having problem signing into Cruise Critic using Microsoft Edge browser?  I get black screens or flashing white screens but it never fully loads.  Thought it might be my computer but I'm using Chrome right now and it's fine...anyone else experiencing this on MS EDGE?

No problem here, try clearing your cached data & cookies. 

Link to post
Share on other sites

I used Microsoft Edge browser for quite some time with great success, but a few months back started having issues with CC as well as other sites with difficulty loading. I switched my default browser back to Chrome and the issues were gone.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Jump
    • Categories
      • Forum Assistance
      • Q&A with the Quark Expeditions Team: New Ship Ultramarine
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...