Jump to content

Anyone having problems with Virgin Voyages Website?


Recommended Posts

I'm wondering if I'm the only one with problems accessing the Virgin website to see my cruise details. It was working right after I made my booking but then suddenly

whenever I tried to log on to my account I get the 404 ERROR page with the seals. I've been working with Virgin for 2 weeks now with no resolution yet. Everyone is very and I've exhausted all that I can do on my end. I even got a call back yesterday for customer support and as of today I still can't access  my account. You can clearly see my account information and my sailing date and information but then the 404 error page comes up obscuring access. Anyone else with this issue?

Link to post
Share on other sites
1 minute ago, biminis said:

I've had the same issue for almost a week. I finally got it resolved on my third attempt calling the service line.  She called someone from support and they reset my account.  Now I can log in fine.

Thanks, I'll call them later and ask them to try resetting my account .I remember they said they have done that already, but no harm in trying that again. Thanks.

Link to post
Share on other sites

I was having trouble accessing my account from a standard browser window that had my login information saved.  It wouldn't even let me logout.  After opening a Private window, I could then log in again and it worked properly.

Edited by timf2001
Link to post
Share on other sites

 

31 minutes ago, kwokpot said:

I'm wondering if I'm the only one with problems accessing the Virgin website to see my cruise details. It was working right after I made my booking but then suddenly

whenever I tried to log on to my account I get the 404 ERROR page with the seals. I've been working with Virgin for 2 weeks now with no resolution yet. Everyone is very and I've exhausted all that I can do on my end. I even got a call back yesterday for customer support and as of today I still can't access  my account. You can clearly see my account information and my sailing date and information but then the 404 error page comes up obscuring access. Anyone else with this issue?

 

This happened on one device of mine. I had to clear all cookies and logins from the site (through the browser's tools). If your login is in the state mine was in, you also can't successfully 'log out', right?


You mentioned multiple devices. Is it possible they are sharing cookies/login info between them?

 

I know you tried incognito mode, but do you have another devices (like a phone) on which you've never logged into the site from? If it works on this other totally new device, it's a problem with the browsers on your other devices, not your VV account. 


Also disable ALL your ad-block while testing. 

Edited by perditax
Link to post
Share on other sites
7 minutes ago, perditax said:

 

 

This happened on one device of mine. I had to clear all cookies and logins from the site (through the browser's tools). If your login is in the state mine was in, you also can't successfully 'log out', right?


You mentioned multiple devices. Is it possible they are sharing cookies/login info between them?

 

I know you tried incognito mode, but do you have another devices (like a phone) on which you've never logged into the site from? If it works on this other totally new device, it's a problem with the browsers on your other devices, not your VV account. 


Also disable ALL your ad-block while testing. 

Just tried to login using my husband's mobile phone which I've never signed on any of his devices. And same issues,so the problem is definitely not on my end.

Incidentally my husband is having the same exact issues with his Virgin account. With so many people having issues it's definitely not  a user issue,it's a website issue.

Link to post
Share on other sites
5 minutes ago, kwokpot said:

Just tried to login using my husband's mobile phone which I've never signed on any of his devices. And same issues,so the problem is definitely not on my end.

Incidentally my husband is having the same exact issues with his Virgin account. With so many people having issues it's definitely not  a user issue,it's a website issue.

 

I'm not trying to 'blame the user', I'm just in IT myself and also had the same issue. 

 

Had your husband logged into the virgin site on that phone already?

Link to post
Share on other sites
2 minutes ago, perditax said:

 

I'm not trying to 'blame the user', I'm just in IT myself and also had the same issue. 

 

Had your husband logged into the virgin site on that phone already?

My husband is also in IT, desktop admin support. 

The answer to your question is yes.

We both have cleared cashed and cookies.

Link to post
Share on other sites
10 minutes ago, kwokpot said:

My husband is also in IT, desktop admin support. 

The answer to your question is yes.

We both have cleared cashed and cookies.

He thinks the best solution is for Virgin to delete our accounts and we start all over. I'm probably going to call them and suggest that.

 

Link to post
Share on other sites
9 minutes ago, kwokpot said:

He thinks the best solution is for Virgin to delete our accounts and we start all over. I'm probably going to call them and suggest that.

 

 

If you guys don't have any bookings/money in the game, seems like it could work, if Virgin CS is even able to do that. 

Link to post
Share on other sites
5 minutes ago, kwokpot said:

We're on the May 3rd Diplo on Deck cruise

 

I'm stopping myself from continuing to ask you tech support questions. 🙂 Sorry I don't know you IRL or I could try to do more. Good luck w/Virgin and their IT (sincerely). The exact same problem was driving me nuts for a while, but it was just the one device. 

Edited by perditax
Link to post
Share on other sites

I had the same issue last week.  Tried using Chrome, Edge, and IE as browsers, including Incognito for Chrome.  No luck.  Then when I called and an agent accessed my booking, I was then able to view my reservation again.

 

My current issue is that the ITS GO TIME button does not function.  My reservation is for a suite, so I thought we'd have access by now.  Anyone have luck when they press the red ITS GO TIME Button?

Link to post
Share on other sites
14 minutes ago, perditax said:

 

I'm stopping myself from continuing to ask you tech support questions. 🙂 Sorry I don't know you IRL or I could try to do more. Good luck w/Virgin and their IT (sincerely). The exact same problem was driving me nuts for a while, but it was just the one device. 

I appreciate your assistance and only looked at your postings for exactly what they are,trying to help a fellow cruiser.

With my husband in IT our technology is always up to date. We have all the latest windows updates and every couple of years he completely rebuilds our desktops by wiping the systems clean and doing a complete new OS install. We have all the necessary security software. Our mobile phones (pixel 2 and 3) are also protected and I literally check for app updates 2x a day. 

Oh did I also mention we have a Tesla Model 3 EV? Love that to death! But that's for another online forum.😜

Link to post
Share on other sites
1 hour ago, Barnmom said:

I am having an issue  on the  "it's go time " tab  to book on board activities. i press the tab and nothing....

 

Yeah, mine turned red a few days ago but doesn’t do anything, I don’t think they have the booking stuff online yet.

Link to post
Share on other sites

Their website is the worst, and has had problems for months-Dec 12th, their app was supposed to go live, didn't.. I still can't book shore things for my April 10th cruise. They said the app will handle it, but if I was in a Rockstar Suite, I could call them to book the activities.  I can't get my account to work on firefox, I have to open it on Safari...

Link to post
Share on other sites
1 hour ago, garymfreedman said:

Their website is the worst, and has had problems for months-Dec 12th, their app was supposed to go live, didn't.. I still can't book shore things for my April 10th cruise. They said the app will handle it, but if I was in a Rockstar Suite, I could call them to book the activities.  I can't get my account to work on firefox, I have to open it on Safari...

The last tech person I spoke yesterday walked that back and said when the app goes live you will not be able to book excursions through it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Jump
    • Categories
      • Forum Assistance
      • Q&A with the Quark Expeditions Team: New Ship Ultramarine
      • Register Now for Cruise Critic Live Special Event: Explore the Remote World with Hurtigruten!
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...