Jump to content
Cruise Critic Community
helene109

Allstate drive wise cards too!

Recommended Posts

I'm not able to load the allstaterewards.com page today via the app or a web browser. Not sure what's up.

Share this post


Link to post
Share on other sites
4 minutes ago, bjd2 said:

I'm not able to load the allstaterewards.com page today via the app or a web browser. Not sure what's up.

I'm having trouble too, so it's not just you all. It finally loaded after a minute or 2. Very sluggish. Almost behaved as though it was under a DOS attack.....I dunno. 

But I finally got in.

Share this post


Link to post
Share on other sites
46 minutes ago, lennythenose said:

Actually waiting on my first card delivery today. Now I have the “Null” problem😂

 

That dumb bug is still around? They probably don't even know it exists. It's going to take someone calling to let them know, but even then, it may not be an Allstate issue. It could be a Deluxe Rewards issue. I don't need any cards, so I guess I'll just wait and see what happens next time.

Share this post


Link to post
Share on other sites
54 minutes ago, Umbrae Noctem said:

Yes, When I try to login into my account it says, "Upgrade Your Account" After I put my birth month and year in, the Site takes me to a page that says, "Unable to Proceed: our online system is unable to complete your registration with the information provided" I can look at my points on the app, that's as far as I can get. I can't redeem, or gain anymore points. 

Having the exact same problem and receiving the exact same error/edit messages Umbrae Noctem.  Spoke with technical support and they verified all of my account information as correct and were unable to provide an explanation as to why my birth month and year will not work.  I have deleted cookies until I don't think I will ever have another one, closed browsers, tried using three different browsers, rebooted my computer but nothing works.  I was finally able to log in (laptop using Windows) using www.allstaterewards.com which allowed me to get in to the rewards site.  I can see my account balance on the mobile app (Android) but that's it.  I'm not an Allstate policy customer in case that ends up having anything to do with it.  

Share this post


Link to post
Share on other sites

i feel like this happens every couple weeks...it usually comes back to normal within a day or two

Share this post


Link to post
Share on other sites
42 minutes ago, Florida Paesano said:

Having the exact same problem and receiving the exact same error/edit messages Umbrae Noctem.  Spoke with technical support and they verified all of my account information as correct and were unable to provide an explanation as to why my birth month and year will not work.  I have deleted cookies until I don't think I will ever have another one, closed browsers, tried using three different browsers, rebooted my computer but nothing works.  I was finally able to log in (laptop using Windows) using www.allstaterewards.com which allowed me to get in to the rewards site.  I can see my account balance on the mobile app (Android) but that's it.  I'm not an Allstate policy customer in case that ends up having anything to do with it.  

 

I could be wrong, but I think that birth date verification page has more to do with policy holders than those of us who just have Rewards accounts. And that's why it doesn't do anything for us. I've seen that page every now again ever since I joined Allstate Rewards almost 3 years ago. It has never done anything and I've always had to clear cookies. I think clicking "Log Out" at the top of that birth date page works as well, but you can't just login after the page refreshes. You have to go back to the rewards page link. For me, that means clicking on my Bookmark.

 

It's probably a long shot, but for those having trouble, try this URL. There was a time when this URL was the only one that worked for us non-Allstate customers (outside of the app). Even now, allstaterewards.com re-routes to this URL: https://myaccountrwd.allstate.com/anon/account/login?campaign=145

Share this post


Link to post
Share on other sites
2 hours ago, Organized Chaos said:

It's probably a long shot, but for those having trouble, try this URL. There was a time when this URL was the only one that worked for us non-Allstate customers (outside of the app). Even now, allstaterewards.com re-routes to this URL: https://myaccountrwd.allstate.com/anon/account/login?campaign=145


Doesn’t work. You have to have a policy with them to create an account. 

Share this post


Link to post
Share on other sites
22 minutes ago, Cruising_Addict said:

Doesn’t work. You have to have a policy with them to create an account. 

 

That URL is for people who already have a Rewards account. Non-Allstate customers have to create a Drivewise-Only account through the app in order to use Allstate Rewards.

 

If you're just getting started, check out my comment here for a rundown on how to create an account as a non-Allstate customer. https://boards.cruisecritic.com/topic/2363984-allstate-drive-wise-cards-too/page/64/?tab=comments#comment-58846129

Share this post


Link to post
Share on other sites
2 hours ago, Cruising_Addict said:


Doesn’t work. You have to have a policy with them to create an account. 

It DOES work. I am not a current Allstate policy holder(I was a few years ago, but not now). And when I click on the link that O.C. posted above, it took me directly to the log in page, WITHOUT any redirect, inbetween web page. I've tried that many times. I go directly to the log in page. 

Share this post


Link to post
Share on other sites
12 minutes ago, MeganGC1983 said:

1500FUNCash

 

Thanks Megan.  I got that one this morning too, but had not posted it yet because I can't log into Allstate Rewards to try it.  Can you log in?

Share this post


Link to post
Share on other sites

I just tried and can't log in. I got this message:

 

503 Service Unavailable

No server is available to handle this request.

Share this post


Link to post
Share on other sites
1 minute ago, Joe817 said:

I just tried and can't log in. I got this message:

 

503 Service Unavailable

No server is available to handle this request.

 

Hmmm??    I was getting that message earlier.    But after PrincessArlena'sDad said he was in, I tried again.   I got an error message saying there was a problem with my login, but it offered me a link to the login page and that worked (same login page as always)

Share this post


Link to post
Share on other sites
1 minute ago, ULCajunCruiser said:

 

Hmmm??    I was getting that message earlier.    But after PrincessArlena'sDad said he was in, I tried again.   I got an error message saying there was a problem with my login, but it offered me a link to the login page and that worked (same login page as always)

Oh I got to the login page all right, but I got that message right after I hit the submit button. 

Share this post


Link to post
Share on other sites
1 minute ago, Joe817 said:

Oh I got to the login page all right, but I got that message right after I hit the submit button. 

 

Darn!!!   Can't imagine what's the problem.   Just went back and checked and I'm in, was able to add the code from MeganGC1983and was able to look around at gift cards!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Forum Jump
    • Categories
      • Forum Assistance
      • Q&A: Cruise Insurance w/ Steve Dasseos of the TripInsuranceStore.com June 2020
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Member Cruise Reviews
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...