Jump to content

Royal Caribbean Website Pain


Recommended Posts

2 minutes ago, minnie00 said:

If i turn off WiFi on my iPad and use cellular data i can access the site....weird 

 

If you have somehow connected to Cellular at Sea, be careful because data costs are very high.

Link to post
Share on other sites
9 minutes ago, Host Clarea said:

 

If you have somehow connected to Cellular at Sea, be careful because data costs are very high.

No i am at home and have an iPad with cellular....i am still not able to get on website on any device or search engine through WiFi 

Link to post
Share on other sites
14 hours ago, minnie00 said:

No i am at home and have an iPad with cellular....i am still not able to get on website on any device or search engine through WiFi 

 

Perhaps some security settings on your router or ISP servers. Have you tried using a WiFi network other than the one at home?

Edited by broberts
Link to post
Share on other sites
35 minutes ago, broberts said:

 

Perhaps some security settings on your router or ISP servers. Have you tried using a WiFi network other than the one at home?

 no I haven't. its weird tho....was fine till 2 days ago

Link to post
Share on other sites

Well, today's pain...  I have four upcoming cruises but with one of them, I'm not able to access the Cruise Planner.  It just takes me back to their home page.  I was able to make a payment on this cruise.  I've tried different browsers and clearing the cache and history.  Weird!

Link to post
Share on other sites
On 8/20/2019 at 8:48 AM, minnie00 said:

 no I haven't. its weird tho....was fine till 2 days ago

This is what was happening to me. Turned off WiFi on my iPhone and could get to website fine. Couldn’t access via WiFi until I emailed them and then it started to work. I have no clue, but it is suspicious.

Link to post
Share on other sites
On 8/22/2019 at 5:36 PM, rhuntington3 said:

And now its working again.  Oh well.

Forgive me for highjacking the thread, but my maiden name is Huntington. I doubt we are related - all my relatives are in the east - but I just had to give a shout out to a fellow RCI cruiser and Huntington!

Link to post
Share on other sites

I normally use Chrome but wasn't able to do check in.  I logged in on Edge a few days ago and voila' it worked.  Drives me crazy.  RCI's site is the only one I use that does this.  Anyway, I got checked in for the second leg of our b2b and have been logging in using Edge ever since.  I prefer Chrome for everything else.  There is no reason for RCI's site to be the way it is except for poor developers and IT dept.   I just tried Chrome and "check in" is still not working.  Glad I'm done but I really shouldn't have to use Edge when Chrome works for every, single, other site I use.

 

Edited by BND
Link to post
Share on other sites
57 minutes ago, MalteseMama2 said:

Forgive me for highjacking the thread, but my maiden name is Huntington. I doubt we are related - all my relatives are in the east - but I just had to give a shout out to a fellow RCI cruiser and Huntington!

 

Always neat to run into another Huntington!

Link to post
Share on other sites

Their website is particularly glitchy today...

 

When I logged into my account.  I says I have 0 cruises upcoming.  Then I logged out and logged back in and I have 4.  I go into cruise planner for the first one, check prices, exit back to upcoming cruise page and she is back to 0 cruises?

 

Tried to check pricing on existing cruises and just get an error screen.

 

Screen Shot 2019-08-31 at 7.35.52 AM.png

 

Done all the usual tricks... cleared cookies, tried different devices, different browsers, gone to incognito mode... No joy.

 

Billion dollar company and a 15¢ IT department.

Edited by Tree_skier
Link to post
Share on other sites

Is anyone else having this problem?  I can log into my account fine.  It's been a long time since my husband last logged in, so long that the website changed to the new format and doesn't recognize his old username/password.  I tried to just create him a new account, using the desktop site, the mobile site and even the app and it keeps getting errors or just plain stuck.

 

I notice that only a minute after I posted  this as a new thread it was merged with a thread that's over 2 years old!  What gives?  This is a new problem, not a continuation of an old one.  Nobody pays attention to ancient threads and having said that, I'm sure my question won't get answered now!!!😡  Thanks alot, moderator!  (NOT)  And I'm assuming that the 2 previous posts weren't originally on this  thread, either.

Edited by Knighton
why was my new thread merged with an ancient one???
Link to post
Share on other sites

so i hope someone will help me because so far rccl doesnt care.so first of all the offical meet and greet rccl cite doesnt work . it read error or cant take reg. right now.we have 18 people and we need 25 our sailing is sept.15 2019. so ive called many time and ask where we could have a informal meet and greet. but i was told even if its only a few mins i must go thru the event department so i have sent several emails but nothing. does anyone have any advice  or have a idea of where on the ship would be a good place to have a meet and greet.we do have many more than 25 people trying to sigh up.i read that this has happened to other sailings

 

 

Link to post
Share on other sites
7 hours ago, sue gill said:

 it read error or cant take reg. right now.we have 18 people and we need 25 our sailing is sept.15 2019. 

Sometimes that error is caused by the device/browser not the site itself. Did you try different device and/or browser?

Link to post
Share on other sites
7 hours ago, sue gill said:

 ... does anyone have any advice  or have a idea of where on the ship would be a good place to have a meet and greet.we do have many more than 25 people trying to sigh up.i read that this has happened to other sailings

 

 

What ship?

Link to post
Share on other sites
On 8/31/2019 at 4:31 PM, Knighton said:

Is anyone else having this problem?  I can log into my account fine.  It's been a long time since my husband last logged in, so long that the website changed to the new format and doesn't recognize his old username/password.  I tried to just create him a new account, using the desktop site, the mobile site and even the app and it keeps getting errors or just plain stuck.

 

I notice that only a minute after I posted  this as a new thread it was merged with a thread that's over 2 years old!  What gives?  This is a new problem, not a continuation of an old one.  Nobody pays attention to ancient threads and having said that, I'm sure my question won't get answered now!!!😡  Thanks alot, moderator!  (NOT)  And I'm assuming that the 2 previous posts weren't originally on this  thread, either.

 

While this thread is quite old, it is also quite active since RCL continues to have serious issues with its website.

 

If you take the time to browse previous posts in this thread you will likely find an answer to the issue mentioned.

Link to post
Share on other sites

Has anyone else experienced a problem with checking in and printing boarding passes?  I got an email from Royal saying I could begin the check in process and I attempted to do it last weekend.  Well after I entered all my info and clicked on continue, the crown and anchor symbol pops us and just keeps on spinning.  I’ve tried every day since and still no luck.  We don’t sail till November so have plenty of time but was just curious if this is normal.  Haven’t sailed with Royal since 2012 and I think they mailed everything to you back then. Thanks.

Link to post
Share on other sites
11 minutes ago, workstocruise said:

Has anyone else experienced a problem with checking in and printing boarding passes?  

Somewhat common issue. Try a different device and/or browser. Also, if available, see if you can do it in the RCI app.

Link to post
Share on other sites
1 hour ago, workstocruise said:

Has anyone else experienced a problem with checking in and printing boarding passes?  I got an email from Royal saying I could begin the check in process and I attempted to do it last weekend.  Well after I entered all my info and clicked on continue, the crown and anchor symbol pops us and just keeps on spinning.  I’ve tried every day since and still no luck.  We don’t sail till November so have plenty of time but was just curious if this is normal.  Haven’t sailed with Royal since 2012 and I think they mailed everything to you back then. Thanks.

 

Call C&A if you cannot get it to work after trying the usual: clear cache, clear cookies, private browsing mode, different browser.

Link to post
Share on other sites

this has happened over weeks of me searching on the site . not limited to one ship or time frame. you will see JR suite or grand suite listed and the prices but when you click on it, the top of the screen says not available. every other cruise site i research wont even show you the room or price if a category isnt available. but even within the rcl site they royal suites never show up because none are available. so why do they have so many issues with this. 

 

just pick a christmas cruise out of NY or balt and see what i mean

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Forum Jump
    • Categories
      • Forum Assistance
      • Holiday Exchange - Jingle and Mingle 2020
      • Q&A: Cruise Insurance with Steve Dasseos of TripInsuranceStore.com
      • Q&A with Chris Prelog, President of Windstar Cruises!
      • New Cruisers
      • Cruise Lines “A – O”
      • Cruise Lines “P – Z”
      • River Cruising
      • ROLL CALLS
      • Digital Photography & Cruise Technology
      • Special Interest Cruising
      • Cruise Discussion Topics
      • UK Cruising
      • Australia & New Zealand Cruisers
      • North American Homeports
      • Ports of Call
      • Cruise Conversations
×
×
  • Create New...